Got Bed Bugs? Bedbugger Forums » Tools/ideas for fighting bed bugs

Missing part of mattress encasement?

(7 posts)
  1. spicynat

    newbite
    Joined: Dec '14
    Posts: 34

    offline

    Posted 5 years ago
    Wed Dec 10 2014 20:41:53
    #



    Login to Send PM

    Hello,

    I just installed a mattress encasement but it looks like something is missing. Shouldn't be something to close tight the zipper as shown in advertise of bug lock/secure seal?
    Or am I supposed to just use some kind of rope to attach the parts together?
    Anyone knows about it?

  2. Warfighter

    newbite
    Joined: Oct '14
    Posts: 36

    offline

    Posted 5 years ago
    Wed Dec 10 2014 21:10:58
    #



    Login to Send PM

    Mine has a velcro strip that covers the zipper and prevents it from loosening. Maybe use one of those twist ties.

  3. BigDummy

    oldtimer
    Joined: Dec '13
    Posts: 4,747

    offline

    Posted 5 years ago
    Wed Dec 10 2014 21:40:21
    #



    Login to Send PM

    Ace Hardware or a similar store will have small zip ties that could be used. Ace generally has them in the electrical section.

  4. P Bello

    oldtimer
    Joined: Nov '11
    Posts: 4,863

    offline

    Posted 5 years ago
    Wed Dec 10 2014 22:06:00
    #



    Login to Send PM

    Pull the fabric loop thru the hole in the zipper and place a paper clip or similar thru it such that the loop is retained in place. A nylon zip or wire twist tie may be used as well.

    Good luck ! pjb

  5. spicynat

    newbite
    Joined: Dec '14
    Posts: 34

    offline

    Posted 5 years ago
    Wed Dec 10 2014 23:29:49
    #



    Login to Send PM

    Thank you so much for your answers! I'll try to buy one or two of these tomorrow.
    I just thought it would come with the encasement.

    Have a good night!

  6. P Bello

    oldtimer
    Joined: Nov '11
    Posts: 4,863

    offline

    Posted 5 years ago
    Wed Dec 10 2014 23:48:38
    #



    Login to Send PM

    Normally, it does. There's supposed to be some sort of hook like thing that attaches the zipper to the loop thing there.

    Perhaps re-check the instructions. It's possible that you have a slightly defective unit there as well but the problem may be easily remedied via the advice that's been posted above.

    pjb

  7. spicynat

    newbite
    Joined: Dec '14
    Posts: 34

    offline

    Posted 5 years ago
    Thu Dec 11 2014 0:00:40
    #



    Login to Send PM

    Thanks! I'll probably try to contact the manufacturer.(even though I'm not sure I want to have to send the product back and wait for them to send me another one)
    In the meantime I'll use your advice


RSS feed for this topic


Reply

You must log in to post.

297,399 posts in 50,188 topics over 156 months by 21,933 of 22,434 members. Latest: Kimmmie46, esedndwi, Help123